summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Schwinge <thomas@codesourcery.com>2014-12-15 11:54:43 +0100
committerThomas Schwinge <tschwinge@gcc.gnu.org>2014-12-15 11:54:43 +0100
commit4b4f2e35d0d71a758079bf11e485f737e7f2b8cf (patch)
treef1633194d56de9a4f584d7032e71716884ae880f /configure.ac
parentf84e7f45f7f8967c82284dc27b545c6fdce6a75b (diff)
Build machinery cleanup.
* configure.ac (--enable-as-accelerator-for): Don't set ENABLE_AS_ACCELERATOR_FOR. Update all users. * configure: Regenerate. From-SVN: r218744
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fd1bdf0f506..91c9a726338 100644
--- a/configure.ac
+++ b/configure.ac
@@ -289,9 +289,7 @@ esac
AC_ARG_ENABLE(as-accelerator-for,
[AS_HELP_STRING([--enable-as-accelerator-for=ARG],
[build as offload target compiler.
- Specify offload host triple by ARG])],
-ENABLE_AS_ACCELERATOR_FOR=$enableval,
-ENABLE_AS_ACCELERATOR_FOR=no)
+ Specify offload host triple by ARG])])
AC_ARG_ENABLE(offload-targets,
[AS_HELP_STRING([--enable-offload-targets=LIST],
@@ -470,7 +468,7 @@ AC_HELP_STRING([[--enable-liboffloadmic[=ARG]]],
*)
AC_MSG_ERROR([--enable-liboffloadmic=no/host/target]) ;;
esac],
-[if test "${ENABLE_AS_ACCELERATOR_FOR}" != "no"; then
+[if test x"$enable_as_accelerator_for" != x; then
case "${target}" in
*-intelmic-* | *-intelmicemul-*)
enable_liboffloadmic=target