summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hongjiu.lu@intel.com>2015-07-14 15:03:11 +0000
committerH.J. Lu <hjl@gcc.gnu.org>2015-07-14 08:03:11 -0700
commit1c01ebf64feab01ac3cee7deb71827d1ff73999e (patch)
tree100c6cb06d3290d764dba0671c6975d0f7023d1b /configure.ac
parent96a58590dd57e67e7ef65f1dee8ee9fa2c460457 (diff)
Sync toplevel files binutils-gdb
Sync with binutils-gdb: 2015-05-01 H.J. Lu <hongjiu.lu@intel.com> PR ld/18355 * Makefile.def: Add extra_configure_flags to host zlib. * configure.ac (extra_host_zlib_configure_flags): New. Set to --enable-host-shared When bfd is to be built as shared library. AC_SUBST. * Makefile.in: Regenerated. From-SVN: r225776
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc77a1baeda..dfc7e75f6d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2271,14 +2271,23 @@ fi
# Sometimes we have special requirements for the host libiberty.
extra_host_libiberty_configure_flags=
+extra_host_zlib_configure_flags=
case " $configdirs " in
*" lto-plugin "* | *" libcc1 "*)
# When these are to be built as shared libraries, the same applies to
# libiberty.
extra_host_libiberty_configure_flags=--enable-shared
;;
+ *" bfd "*)
+ # When bfd is to be built as a shared library, the same applies to
+ # zlib.
+ if test "$enable_shared" = "yes"; then
+ extra_host_zlib_configure_flags=--enable-host-shared
+ fi
+ ;;
esac
AC_SUBST(extra_host_libiberty_configure_flags)
+AC_SUBST(extra_host_zlib_configure_flags)
# Produce a warning message for the subdirs we can't configure.
# This isn't especially interesting in the Cygnus tree, but in the individual