summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Burnus <tobias@codesourcery.com>2021-04-28 18:46:47 +0200
committerTobias Burnus <tobias@codesourcery.com>2021-04-28 18:46:47 +0200
commitfe5bfa6704179f8db7d1ae0b485439e9896df8eb (patch)
tree7687db287a1ef04b1399cf8db2a06eb9398cc995 /configure.ac
parent3da80ed7efd582575e7850a403ce693ec882d087 (diff)
offload-defaulted: Config option to silently ignore uninstalled offload compilers
If configured with --enable-offload-defaulted, configured but not installed offload compilers and libgomp plugins are silently ignored. Useful for distribution compilers where those are in separate optional packages. 2021-04-28 Jakub Jelinek <jakub@redhat.com> Tobias Burnus <tobias@codesourcery.com> ChangeLog: * configure.ac (--enable-offload-defaulted): New. * configure: Regenerate. gcc/ChangeLog: * configure.ac (OFFLOAD_DEFAULTED): AC_DEFINE if offload-defaulted. * gcc.c (process_command): New variable. (driver::maybe_putenv_OFFLOAD_TARGETS): If OFFLOAD_DEFAULTED, set it if -foffload is defaulted. * lto-wrapper.c (OFFLOAD_TARGET_DEFAULT_ENV): Define. (compile_offload_image): If OFFLOAD_DEFAULTED and OFFLOAD_TARGET_DEFAULT is in the environment, don't fail if corresponding mkoffload can't be found. (compile_images_for_offload_targets): Likewise. Free and clear offload_names if no valid offload is found. * config.in: Regenerate. * configure: Regenerate. libgomp/ChangeLog: * configure.ac (OFFLOAD_DEFAULTED): AC_DEFINE if offload-defaulted. * target.c (gomp_load_plugin_for_device): If set and if a plugin can't be dlopened, silently assume it has no devices. * Makefile.in: Regenerate. * config.h.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 088e735c5db..b923b0bb9cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -300,6 +300,14 @@ AC_ARG_ENABLE(offload-targets,
fi
], [enable_offload_targets=])
+AC_ARG_ENABLE(offload-defaulted,
+[AS_HELP_STRING([--enable-offload-defaulted]
+ [If enabled, configured but not installed offload compilers and
+ libgomp plugins are silently ignored. Useful for distribution
+ compilers where those are in separate optional packages.])],
+[enable_offload_defaulted=$enableval],
+[enable_offload_defaulted=])
+
# Handle --enable-gold, --enable-ld.
# --disable-gold [--enable-ld]
# Build only ld. Default option.