aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Savoye <rob.savoye@linaro.org>2014-07-28 11:01:49 -0600
committerRob Savoye <rob.savoye@linaro.org>2014-07-28 11:01:49 -0600
commitd109c3d194f1030a406e96a7a5dfc36e32e38dd4 (patch)
tree614b25f43a4733ed8a440a1a51f96b56530fc611 /configure.ac
parent042243b56341e1e362ed5e7637d99d0b7950cf32 (diff)
add test for ccrypt, which is needed for benchmarks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90f9fa67..7a9ef250 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,6 +109,12 @@ if test x"${AUTOGEN}" = x; then
missing="${missing} autogen"
fi
+AC_PATH_PROG(CCRYPT, ccrypt)
+if test x"${CCRYPT}" = x; then
+ AC_MSG_WARN([You need 'ccrypt' to run benchmarks, this can be ignored for builds])
+ missing="${missing} ccrypt"
+fi
+
dnl Building GDB requires ncurses and termcap
#AC_CHECK_LIB(ncurses, doupdate)
#if test x${ac_cv_lib_ncurses_doupdate} != x"yes"; then