aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Savoye <rob.savoye@linaro.org>2013-11-20 12:24:47 -0700
committerRob Savoye <rob.savoye@linaro.org>2013-11-20 12:24:47 -0700
commitd3911aa3181b0081f4af7641a865fd7ee1cbd189 (patch)
tree6280a559277e8c17a614d873348efa5b659d9e6d /configure.ac
parente09385288752c87978ad23d2a43fa6ba78b615d3 (diff)
use uname -m instead of uname -p, as the chroots return unknown otherwise
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3b519a63..d4600182 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,7 +247,7 @@ AC_SUBST(LIBC)
KERNEL="`uname -r`"
AC_SUBST(KERNEL)
BUILDHOST="`${srcdir}/config.guess`"
-BUILD_ARCH="`uname -p`"
+BUILD_ARCH="`uname -m`"
if test x"${BUILD_ARCH}" = x"x86_64" -a -f /etc/debian_chroot; then
BUILD_ARCH=i486
BUILDHOST="`echo ${BUILDHOST} | sed -e 's:x86_64:i486:'`"