aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChad Versace <chad.versace@linux.intel.com>2012-05-17 15:22:18 -0700
committerChad Versace <chad.versace@linux.intel.com>2012-05-23 21:57:09 -0700
commitf70bc3a1cd2aaf3979fd8acff43d8866a7b08813 (patch)
tree7b82e2be1d121cc738495e1548dfcb664a74a0b3 /CMakeLists.txt
parent47d0730191d5c22f66d6cc63c6b11cd2acee285d (diff)
cmake: Add option USE_WAFFLE
If enabled, Piglit will use Waffle in place of GLUT. The option is disabled by default. As of this patch, however, enabling this option does nothing but require libwaffle. Future patches will integrate Waffl into Piglit. Reviewed-by: Pauli Nieminen <pauli.nieminen@intel.com> Reviewed-by: Jordan Justen <jordan.l.justen@intel.com> Reviewed-by: Anuj Phogat <anuj.phogat@gmail.com> Signed-off-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6774a7e7..3c2b99a5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,14 @@ find_package(X11)
option(BUILD_GLES1_TESTS "Build tests for OpenGL ES1" OFF)
option(BUILD_GLES2_TESTS "Build tests for OpenGL ES2" OFF)
+option(USE_WAFFLE "Use Waffle in place of GLUT" OFF)
+if(USE_WAFFLE)
+ # FIXME: Specify version requirements for Waffle.
+ find_package(Waffle REQUIRED)
+ add_definitions(-DUSE_WAFFLE)
+ include_directories("${WAFFLE_INCLUDE_DIR}")
+endif(USE_WAFFLE)
+
IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
option(BUILD_GLX_TESTS "Build tests that require GLX" ON)
ELSE()