aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch')
-rw-r--r--meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch b/meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch
new file mode 100644
index 0000000..111ab25
--- /dev/null
+++ b/meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch
@@ -0,0 +1,27 @@
+Index: re2/Makefile
+===================================================================
+--- re2.orig/Makefile
++++ re2/Makefile
+@@ -9,18 +9,18 @@ all: obj/libre2.a obj/so/libre2.so
+ # CCPCRE=-I/usr/local/include -DUSEPCRE
+ # LDPCRE=-L/usr/local/lib -lpcre
+
+-CXX=g++
++# CXX=g++
+ CXXFLAGS=-Wall -O3 -g -pthread # can override
+ RE2_CXXFLAGS=-Wno-sign-compare -c -I. $(CCPCRE) # required
+ LDFLAGS=-pthread
+-AR=ar
++#AR=ar
+ ARFLAGS=rsc
+-NM=nm
++#NM=nm
+ NMFLAGS=-p
+
+ # Variables mandated by GNU, the arbiter of all good taste on the internet.
+ # http://www.gnu.org/prep/standards/standards.html
+-prefix=/usr/local
++prefix=/usr
+ exec_prefix=$(prefix)
+ bindir=$(exec_prefix)/bin
+ includedir=$(prefix)/include