aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2014-02-21 16:56:04 -0600
committerTom Gall <tom.gall@linaro.org>2014-02-21 16:56:04 -0600
commitea47480fbcdcfebbd4bb47d150789e42061bc54c (patch)
tree77e16be20fc26e4ff07842d003c1e58cdeada374
parent4b4db23227a465570de4624098f2227aae45d12b (diff)
Add recipe for libspeechd a speech synthesis and dispatcher library
-rw-r--r--meta-linaro/recipes-multimedia/libspeechd/libspeechd-0.8/0023-tgall-espeak-fix-include.patch13
-rw-r--r--meta-linaro/recipes-multimedia/libspeechd/libspeechd_0.8.bb22
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-linaro/recipes-multimedia/libspeechd/libspeechd-0.8/0023-tgall-espeak-fix-include.patch b/meta-linaro/recipes-multimedia/libspeechd/libspeechd-0.8/0023-tgall-espeak-fix-include.patch
new file mode 100644
index 0000000..aa8bdc6
--- /dev/null
+++ b/meta-linaro/recipes-multimedia/libspeechd/libspeechd-0.8/0023-tgall-espeak-fix-include.patch
@@ -0,0 +1,13 @@
+Index: speech-dispatcher-0.8-beta1/src/modules/espeak.c
+===================================================================
+--- speech-dispatcher-0.8-beta1.orig/src/modules/espeak.c 2012-07-11 04:05:06.000000000 -0500
++++ speech-dispatcher-0.8-beta1/src/modules/espeak.c 2013-07-10 16:30:00.545898662 -0500
+@@ -37,7 +37,7 @@
+ #include <semaphore.h>
+
+ /* espeak header file */
+-#include <espeak/speak_lib.h>
++#include <speak_lib.h>
+ #ifndef ESPEAK_API_REVISION
+ #define ESPEAK_API_REVISION 1
+ #endif
diff --git a/meta-linaro/recipes-multimedia/libspeechd/libspeechd_0.8.bb b/meta-linaro/recipes-multimedia/libspeechd/libspeechd_0.8.bb
new file mode 100644
index 0000000..641d235
--- /dev/null
+++ b/meta-linaro/recipes-multimedia/libspeechd/libspeechd_0.8.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "libspeechd Speech Dispatcher project provides a high-level device independent layer for access to speech synthesis through a simple, stable and well documented interface"
+HOMEPAGE = "http://devel.freebsoft.org/speechd"
+
+LICENSE = ""
+LIC_FILES_CHKSUM = "file://COPYING;md5=5828ebb4b7590269a994ed46b0a70df0"
+
+DEPENDS = "libdotconf espeak"
+
+SRC_URI = "http://devel.freebsoft.org/pub/projects/speechd/speech-dispatcher-${PV}-beta1.tar.gz \
+ file://0023-tgall-espeak-fix-include.patch"
+
+SECTION = "libs"
+
+PR = "r1"
+
+SRC_URI[md5sum] = "96f8067a9796d1682c65925f867c3e7f"
+SRC_URI[sha256sum] = "eb60069f291008717c429aff210afe6075c24b68b8de75fe16d9298e85cbac5c"
+
+S = "${WORKDIR}/speech-dispatcher-${PV}-beta1"
+
+inherit autotools
+