aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Taylor <rob.taylor@codethink.co.uk>2008-11-14 13:01:03 +0000
committerRob Taylor <rob.taylor@codethink.co.uk>2008-11-14 13:01:03 +0000
commit82383272d5df49fbba1e8ae3475c412b4cd1152e (patch)
tree132ae3880417a9bc764887f9b156f7abc5d31398 /configure.ac
parentf093f217b025ba668f0b82b05f95088db15661be (diff)
check for documentation generation dependancies
Only build documentation if perl, XML::LibXML::Reader and the relevent xml tools are available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b6143d90..1ad529e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,10 @@ AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Honor aclocal flags
+ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+AC_CONFIG_MACRO_DIR(m4)
+
AC_PROG_CC
AM_PROG_CC_C_O
AC_DISABLE_STATIC
@@ -12,18 +16,29 @@ AC_PROG_LIBTOOL
AC_PATH_PROG(VALAC, valac, valac)
AC_SUBST(VALAC)
+build_docs=yes
+
XSLTPROC=
AC_CHECK_PROGS([XSLTPROC], [xsltproc])
if test -z "$XSLTPROC"; then
- AC_MSG_ERROR([xsltproc (from the libxslt source package) is required])
+ AC_MSG_WARN([xsltproc (from the libxslt source package) not found, not building documentation])
+ build_docs=no
fi
XMLLINT=
AC_CHECK_PROGS([XMLLINT], [xmllint])
if test -z "$XMLLINT"; then
- AC_MSG_ERROR([xmllint (from the libxml2-utils source package) is required])
+ AC_MSG_WARN([xmllint (from the libxml2-utils source package) not found, not building documentation])
+ build_docs=no
fi
+AC_PROG_PERL_MODULES([XML::LibXML::Reader], [],
+[
+ build_docs=no
+])
+
+AM_CONDITIONAL(CONTEXTKIT_BUILD_DOCS, test x$build_docs= xyes)
+
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(LDFLAGS)