aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Janzso <ext-david.2.janzso@nokia.com>2008-11-11 19:33:11 +0200
committerDavid Janzso <ext-david.2.janzso@nokia.com>2008-11-11 19:33:11 +0200
commit2480806969dcea047ac21bb08885f09291ad98fd (patch)
tree45cc382c4d1693cb40b3e672bbee21841c5ffe6c /configure.ac
parentf9b82bfa71ad0ed350555082acc037d34b0156b3 (diff)
check for the presence of xmllint
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 198b1b80..b6143d90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,12 @@ if test -z "$XSLTPROC"; then
AC_MSG_ERROR([xsltproc (from the libxslt source package) is required])
fi
+XMLLINT=
+AC_CHECK_PROGS([XMLLINT], [xmllint])
+if test -z "$XMLLINT"; then
+ AC_MSG_ERROR([xmllint (from the libxml2-utils source package) is required])
+fi
+
AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(LDFLAGS)