aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2011-08-09 14:49:46 -0500
committerTom Gall <tom.gall@linaro.org>2011-08-09 14:49:46 -0500
commit4a72099711359606b1fc10c1744057a6c568d5d8 (patch)
tree9413089fe9922a1a0e23c4739bd87caf5f357877 /Makefile.am
parent0c0e874b223e9ccc4a756c471f8792102b2d34a4 (diff)
Sync with mainline apply everything between 1.1.1 to 8/8/2011
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am111
1 files changed, 80 insertions, 31 deletions
diff --git a/Makefile.am b/Makefile.am
index 005f040..f384eab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,19 +34,35 @@ libjpeg_la_SOURCES += jdarith.c
endif
-libturbojpeg_la_SOURCES = $(libjpeg_la_SOURCES) turbojpegl.c turbojpeg.h \
- turbojpeg-mapfile
+libturbojpeg_la_SOURCES = $(libjpeg_la_SOURCES) turbojpeg.c turbojpeg.h \
+ transupp.c transupp.h jdatadst-tj.c jdatasrc-tj.c
+
+SUBDIRS = java
+
+if WITH_JAVA
+
+libturbojpeg_la_SOURCES += turbojpeg-jni.c
+libturbojpeg_la_CFLAGS = ${JNI_CFLAGS}
+TJMAPFILE = turbojpeg-mapfile.jni
+
+else
+
+TJMAPFILE = turbojpeg-mapfile
+
+endif
+
+libturbojpeg_la_SOURCES += $(TJMAPFILE)
if VERSION_SCRIPT
-libturbojpeg_la_LDFLAGS += $(VERSION_SCRIPT_FLAG)$(srcdir)/turbojpeg-mapfile
+libturbojpeg_la_LDFLAGS += $(VERSION_SCRIPT_FLAG)$(srcdir)/$(TJMAPFILE)
libjpeg_la_LDFLAGS += $(VERSION_SCRIPT_FLAG)libjpeg.map
endif
if WITH_SIMD
-SUBDIRS = simd
+SUBDIRS += simd
libjpeg_la_LIBADD = simd/libsimd.la
libturbojpeg_la_LIBADD = simd/libsimd.la
@@ -56,18 +72,19 @@ libjpeg_la_SOURCES += jsimd_none.c
endif
-TSTHDRS = rrutil.h rrtimer.h
+bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom tjbench
+noinst_PROGRAMS = tjunittest
-bin_PROGRAMS = cjpeg djpeg jpegtran rdjpgcom wrjpgcom jpgtest
-noinst_PROGRAMS = jpegut
+tjbench_SOURCES = tjbench.c bmp.h bmp.c tjutil.h tjutil.c rdbmp.c rdppm.c \
+ wrbmp.c wrppm.c
-jpgtest_SOURCES = $(TSTHDRS) jpgtest.c bmp.h bmp.c
+tjbench_LDADD = libturbojpeg.la libjpeg.la -lm
-jpgtest_LDADD = libturbojpeg.la -lm
+tjbench_CFLAGS = -DBMP_SUPPORTED -DPPM_SUPPORTED
-jpegut_SOURCES = $(TSTHDRS) jpegut.c bmp.h bmp.c
+tjunittest_SOURCES = tjunittest.c tjutil.h tjutil.c
-jpegut_LDADD = libturbojpeg.la
+tjunittest_LDADD = libturbojpeg.la
cjpeg_SOURCES = cdjpeg.h cderror.h cdjpeg.c cjpeg.c rdbmp.c rdgif.c \
rdppm.c rdswitch.c rdtarga.c
@@ -102,24 +119,33 @@ dist_man1_MANS = cjpeg.1 djpeg.1 jpegtran.1 rdjpgcom.1 wrjpgcom.1
DOCS= README install.txt usage.txt wizard.txt example.c libjpeg.txt \
structure.txt coderules.txt filelist.txt jconfig.txt change.log \
- README-turbo.txt rdrle.c wrrle.c LICENSE.txt LGPL.txt BUILDING.txt \
- ChangeLog.txt
+ README-turbo.txt rdrle.c wrrle.c BUILDING.txt ChangeLog.txt
TESTFILES= testorig.jpg testorig.ppm testimg.bmp testimgflt.jpg \
testimgfst.jpg testimgint.jpg testimgp.jpg testimgflt.ppm testimgfst.ppm \
testimgint.ppm testimgflt-nosimd.jpg testimgcrop.jpg testimgari.jpg \
- testimgari.ppm testimgfst100.jpg
+ testimgari.ppm testimgfst100.jpg testimggray.jpg testimgfst1_2.ppm \
+ testimgfst1_4.ppm testimgfst1_8.ppm testimgint1_2.ppm testimgint1_4.ppm \
+ testimgint1_8.ppm
+
EXTRA_DIST = win release $(DOCS) $(TESTFILES) CMakeLists.txt \
- sharedlib/CMakeLists.txt cmakescripts libjpeg.map.in
+ sharedlib/CMakeLists.txt cmakescripts libjpeg.map.in doc doxygen.config
dist-hook:
rm -rf `find $(distdir) -name .svn`
test: testclean all
- ./jpegut
- ./jpegut -yuv
+if WITH_JAVA
+ $(JAVA) -cp java/turbojpeg.jar -Djava.library.path=.libs TJUnitTest
+ $(JAVA) -cp java/turbojpeg.jar -Djava.library.path=.libs TJUnitTest -bi
+ $(JAVA) -cp java/turbojpeg.jar -Djava.library.path=.libs TJUnitTest -yuv
+ $(JAVA) -cp java/turbojpeg.jar -Djava.library.path=.libs TJUnitTest -yuv -bi
+endif
+ ./tjunittest
+ ./tjunittest -alloc
+ ./tjunittest -yuv
./cjpeg -dct int -outfile testoutint.jpg $(srcdir)/testorig.ppm
cmp $(srcdir)/testimgint.jpg testoutint.jpg
./cjpeg -dct fast -opt -outfile testoutfst.jpg $(srcdir)/testorig.ppm
@@ -127,21 +153,35 @@ test: testclean all
./cjpeg -dct fast -quality 100 -opt -outfile testoutfst100.jpg $(srcdir)/testorig.ppm
cmp $(srcdir)/testimgfst100.jpg testoutfst100.jpg
./cjpeg -dct float -outfile testoutflt.jpg $(srcdir)/testorig.ppm
-if WITH_SIMD
+if WITH_SSE_FLOAT_DCT
cmp $(srcdir)/testimgflt.jpg testoutflt.jpg
else
cmp $(srcdir)/testimgflt-nosimd.jpg testoutflt.jpg
endif
+ ./cjpeg -dct int -grayscale -outfile testoutgray.jpg $(srcdir)/testorig.ppm
+ cmp $(srcdir)/testimggray.jpg testoutgray.jpg
./djpeg -dct int -fast -ppm -outfile testoutint.ppm $(srcdir)/testorig.jpg
cmp $(srcdir)/testimgint.ppm testoutint.ppm
./djpeg -dct fast -ppm -outfile testoutfst.ppm $(srcdir)/testorig.jpg
cmp $(srcdir)/testimgfst.ppm testoutfst.ppm
./djpeg -dct float -ppm -outfile testoutflt.ppm $(srcdir)/testorig.jpg
-if WITH_SIMD
+if WITH_SSE_FLOAT_DCT
cmp $(srcdir)/testimgflt.ppm testoutflt.ppm
else
cmp $(srcdir)/testorig.ppm testoutflt.ppm
endif
+ ./djpeg -dct int -scale 1/2 -ppm -outfile testoutint1_2.ppm $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgint1_2.ppm testoutint1_2.ppm
+ ./djpeg -dct fast -scale 1/2 -ppm -outfile testoutfst1_2.ppm $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgfst1_2.ppm testoutfst1_2.ppm
+ ./djpeg -dct int -scale 1/4 -ppm -outfile testoutint1_4.ppm $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgint1_4.ppm testoutint1_4.ppm
+ ./djpeg -dct fast -scale 1/4 -ppm -outfile testoutfst1_4.ppm $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgfst1_4.ppm testoutfst1_4.ppm
+ ./djpeg -dct int -scale 1/8 -ppm -outfile testoutint1_8.ppm $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgint1_8.ppm testoutint1_8.ppm
+ ./djpeg -dct fast -scale 1/8 -ppm -outfile testoutfst1_8.ppm $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgfst1_8.ppm testoutfst1_8.ppm
./djpeg -dct int -bmp -colors 256 -outfile testout.bmp $(srcdir)/testorig.jpg
cmp $(srcdir)/testimg.bmp testout.bmp
if WITH_ARITH_ENC
@@ -166,22 +206,31 @@ endif
testclean:
rm -f testout*
- rm -f *_GRAYQ[0-9]*.bmp
- rm -f *_GRAYQ[0-9]*.ppm
- rm -f *_GRAYQ[0-9]*.jpg
+ rm -f *_GRAY_*.bmp
+ rm -f *_GRAY_*.png
+ rm -f *_GRAY_*.ppm
+ rm -f *_GRAY_*.jpg
rm -f *_GRAY.yuv
- rm -f *_420Q[0-9]*.bmp
- rm -f *_420Q[0-9]*.ppm
- rm -f *_420Q[0-9]*.jpg
+ rm -f *_420_*.bmp
+ rm -f *_420_*.png
+ rm -f *_420_*.ppm
+ rm -f *_420_*.jpg
rm -f *_420.yuv
- rm -f *_422Q[0-9]*.bmp
- rm -f *_422Q[0-9]*.ppm
- rm -f *_422Q[0-9]*.jpg
+ rm -f *_422_*.bmp
+ rm -f *_422_*.png
+ rm -f *_422_*.ppm
+ rm -f *_422_*.jpg
rm -f *_422.yuv
- rm -f *_444Q[0-9]*.bmp
- rm -f *_444Q[0-9]*.ppm
- rm -f *_444Q[0-9]*.jpg
+ rm -f *_444_*.bmp
+ rm -f *_444_*.png
+ rm -f *_444_*.ppm
+ rm -f *_444_*.jpg
rm -f *_444.yuv
+ rm -f *_440_*.bmp
+ rm -f *_440_*.png
+ rm -f *_440_*.ppm
+ rm -f *_440_*.jpg
+ rm -f *_440.yuv
if X86_64