aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2012-01-09 22:30:05 +0000
committerTom Gall <tom.gall@linaro.org>2012-01-09 22:30:05 +0000
commitfe79f24448e3eba6fb5c36ecd1879d391fa2c28b (patch)
tree0c5267a3fa51867d1acab70809edb4ae8aacb814 /Makefile.am
parent4171e24e7e9451847571afc9977ec066d9b9f804 (diff)
Change Makefile.am to have same build flags as android for purposes of locked down test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f384eab..e78342f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,8 @@
lib_LTLIBRARIES = libjpeg.la libturbojpeg.la
libjpeg_la_LDFLAGS = -version-info ${SO_MAJOR_VERSION}:${SO_MINOR_VERSION} -no-undefined
libturbojpeg_la_LDFLAGS = -avoid-version -no-undefined
+libturbojpeg_la_CFLAGS = -DAVOID_TABLES -O3 -fstrict-aliasing -fprefetch-loop-arrays -DANDROID \
+ -DANDROID_TILE_BASED_DECODE -DENABLE_ANDROID_NULL_CONVERT
include_HEADERS = jerror.h jmorecfg.h jpeglib.h turbojpeg.h
nodist_include_HEADERS = jconfig.h
@@ -42,7 +44,7 @@ SUBDIRS = java
if WITH_JAVA
libturbojpeg_la_SOURCES += turbojpeg-jni.c
-libturbojpeg_la_CFLAGS = ${JNI_CFLAGS}
+libturbojpeg_la_CFLAGS += ${JNI_CFLAGS}
TJMAPFILE = turbojpeg-mapfile.jni
else