aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Elliston <bje@gnu.org>2006-06-06 05:35:21 +0000
committerBen Elliston <bje@gnu.org>2006-06-06 05:35:21 +0000
commitb3ee71c2e357d7a0c4907aa8bb6d862d9dc0067a (patch)
tree2957ed251dc7d07ef8f56d96545c228026e48878 /Makefile.am
parent943990d8f766af6438dd57f610642e84e012217c (diff)
* Makefile.am (CONTRIB): New.
(EXTRA_DIST): Add $(CONTRIB). (doc/dejagnu.texi): Set directory-category param to docbook2texi. * Makefile.in: Regenerate. * doc/dejagnu.texi: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 524ea6d..bf79264 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ EXTRA_DIST = ChangeLog.0 MAINTAINERS runtest site.tmpl \
$(pkgdata_DATA) $(pkgdata_SCRIPTS) \
$(config_DATA) $(config_SCRIPTS) \
$(baseboard_DATA) $(baseboard_SCRIPTS) \
- $(TESTSUITE_FILES) $(XML)
+ $(TESTSUITE_FILES) $(XML) $(CONTRIB)
bin_SCRIPTS = runtest
include_HEADERS = dejagnu.h
@@ -165,6 +165,10 @@ pkgdata_DATA = stub-loader.c testglue.c
djlibexecdir = $(pkgdatadir)/libexec
djlibexec_SCRIPTS = config.guess
+# Contributed scripts, etc.
+
+CONTRIB = contrib/compare_tests
+
# Testsuite.
TESTSUITE_FILES = \
@@ -220,7 +224,7 @@ html:
$(DOCBOOK2HTML) -o html $(srcdir)/doc/dejagnu.xml
doc/dejagnu.texi: $(XML)
- $(DOCBOOK2TEXI) --string-param directory-description="The GNU testing framework." $(srcdir)/doc/dejagnu.xml
+ $(DOCBOOK2TEXI) --string-param directory-description="The GNU testing framework." --string-param directory-category="Programming" $(srcdir)/doc/dejagnu.xml
mv dejagnu.texi $(srcdir)/doc
# Packaging.