aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Elliston <bje@gnu.org>2008-04-07 14:48:21 +1000
committerBen Elliston <bje@gnu.org>2008-04-07 14:49:27 +1000
commit7cd597d12ffd161206a468963fb791ffa833086e (patch)
tree0848199f286311055864ea8b82634e34a6ad7b78 /Makefile.am
parent7366d4887cca6839218272fc298cd1a1fb708b39 (diff)
Make the testsuite work better.
* Makefile.am (RUNTESTDEFAULTFLAGS): Add RUNTEST=$(RUNTEST). * Makefile.in: Regenerate. * dejagnu.exp (host_execute): Improve regexp matching. * testsuite/libdejagnu/unit.cc: C++ fixes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e51659..c027bcd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -195,7 +195,7 @@ TESTSUITE_FILES = \
testsuite/libdejagnu/tunit.exp
RUNTEST = ${top_srcdir}/runtest
-RUNTESTDEFAULTFLAGS = --srcdir $(srcdir)/testsuite
+RUNTESTDEFAULTFLAGS = --srcdir $(srcdir)/testsuite RUNTEST=$(RUNTEST)
AM_CXXFLAGS = -I$(top_srcdir) -g
check_PROGRAMS = unit