summaryrefslogtreecommitdiff
path: root/libctf/configure.ac
diff options
context:
space:
mode:
authorIndu Bhagat <indu.bhagat@oracle.com>2022-12-12 10:41:06 -0800
committerIndu Bhagat <indu.bhagat@oracle.com>2022-12-12 10:53:39 -0800
commitf5b6601dae0ad2cb90952c16beac8a762915ee48 (patch)
tree86f25db8f27ba8eaa89b4d163bfcf5b96d5c445c /libctf/configure.ac
parentc6c1fccd8f53b2129830a51cd1b6d91ba7e98f1d (diff)
libctf: remove unnecessary zstd constructs
This patch is essentially a revert of commit-id: 8818c80cbd4116ef5af171ec47c61167179e225c (libctf: Add ZSTD_LIBS to LIBS so that ac_cv_libctf_bfd_elf can be true) As the specific configure check now uses libtool, this explicit mention of the dependency $ZSTD_LIBS is not needed anymore. ChangeLog: * libctf/Makefile.in: Regenerated. * libctf/aclocal.m4: Likewise. * libctf/config.h.in: Likewise. * libctf/configure: Likewise. * libctf/configure.ac: Remove ZSTD_LIBS from LIBS. Cleanup unused AC_ZSTD.
Diffstat (limited to 'libctf/configure.ac')
-rw-r--r--libctf/configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/libctf/configure.ac b/libctf/configure.ac
index 0e0495ba6ef..65686fedc5a 100644
--- a/libctf/configure.ac
+++ b/libctf/configure.ac
@@ -69,7 +69,6 @@ AC_FUNC_MMAP
# Needed for BFD capability checks.
AC_SEARCH_LIBS(dlsym, dl)
AM_ZLIB
-AC_ZSTD
GCC_ENABLE([libctf-hash-debugging], [no], [], [Enable expensive debugging of CTF deduplication type hashing])
if test "${enable_libctf_hash_debugging}" = yes; then
@@ -89,7 +88,7 @@ CC="./libtool --quiet --mode=link $OLD_CC"
CFLAGS="-I${srcdir}/../include -I../bfd -I${srcdir}/../bfd $CFLAGS"
LDFLAGS="-L../bfd -L../libiberty $LDFLAGS"
intl=`echo $LIBINTL | sed 's,${top_builddir}/,,g'`
-LIBS="-lbfd -liberty $ZSTD_LIBS $intl $LIBS"
+LIBS="-lbfd -liberty $intl $LIBS"
AC_CACHE_CHECK([for ELF support in BFD], ac_cv_libctf_bfd_elf,
[AC_TRY_LINK([#include <stdlib.h>
#include <string.h>