summaryrefslogtreecommitdiff
path: root/libctf/configure.ac
diff options
context:
space:
mode:
authorNick Alcock <nick.alcock@oracle.com>2021-02-03 14:09:02 +0000
committerNick Alcock <nick.alcock@oracle.com>2021-02-10 15:26:57 +0000
commit758f590744b1cf8d1049fca3223d1817242cacb8 (patch)
tree3369d81a7aaf785458ee67b3263649db214c0a5a /libctf/configure.ac
parentcbd8f5bbcc81ffe6c84bd6439c9a22976867e4ad (diff)
libctf: add missing header in BFD ELF check
Without this, GCC warns: In file included from conftest.c:36: ../../libctf/../bfd/elf-bfd.h: In function 'bfd_section_is_ctf': ../../libctf/../bfd/elf-bfd.h:3089:10: warning: implicit declaration of function 'strncmp' [-Wimplicit-function-declaration] 3089 | return strncmp (name, ".ctf", 4) == 0 && (name[4] == 0 || name[4] == '.'); | ^~~~~~~ ../../libctf/../bfd/elf-bfd.h:3089:33: warning: 'strncmp' argument 3 type is 'int' where 'long unsigned int' is expected in a call to built-in function declared without prototype [-Wbuiltin-declaration-mismatch] 3089 | return strncmp (name, ".ctf", 4) == 0 && (name[4] == 0 || name[4] == '.'); | ^ <built-in>: note: built-in 'strncmp' declared here These warnings do not currently throw off the result of the configure check, but it's better to squash them anyway. libctf/ChangeLog 2021-02-03 Nick Alcock <nick.alcock@oracle.com> * configure.ac (ac_cv_libctf_bfd_elf): Include string.h. * configure: Regenerated.
Diffstat (limited to 'libctf/configure.ac')
-rw-r--r--libctf/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/libctf/configure.ac b/libctf/configure.ac
index c6b80442e07..90e3c437d60 100644
--- a/libctf/configure.ac
+++ b/libctf/configure.ac
@@ -88,6 +88,7 @@ intl=`echo $LIBINTL | sed 's,${top_builddir}/,,g'`
LIBS="-lbfd -liberty -lz $intl $LIBS"
AC_CACHE_CHECK([for ELF support in BFD], ac_cv_libctf_bfd_elf,
[AC_TRY_LINK([#include <stdlib.h>
+ #include <string.h>
#include "bfd.h"
#include "elf-bfd.h"],
[(void) bfd_section_from_elf_index (NULL, 0);