summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorClément Chigot <chigot@adacore.com>2023-01-03 14:24:43 +0100
committerClément Chigot <chigot@adacore.com>2023-01-06 09:32:07 +0100
commit5fb0e308577143ceb313fde5538dc9ecb038f29f (patch)
tree3f68073bc5274f2e2a40e9f7dd151c947df379cf /configure.ac
parentdcd469925324f430e8cf656c7f63538dd7a01d08 (diff)
configure: remove dependencies on gmp and mpfr when gdb is disabled
Since 991180627851801f1999d1ebbc0e569a17e47c74, the configure checks about GMP and MPFR for gdb builds have been moved to the toplevel configure. However, it doesn't take into account the --disable-gdb option. Meaning that a build without gdb will require these libraries even if not needed. ChangeLog: * configure.ac: Skip GMP and MPFR when --disable-gdb is provided. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3a1eb0357e5..e95a9ed116e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1585,7 +1585,9 @@ if test -d ${srcdir}/gcc ; then
require_mpc=yes
fi
if test -d ${srcdir}/gdb ; then
- require_gmp=yes
+ if test "x$enable_gdb" != xno; then
+ require_gmp=yes
+ fi
fi
gmplibs="-lmpfr -lgmp"