summaryrefslogtreecommitdiff
path: root/meta-rtmod1/recipes-training/rt-demoapps/rt-demo-kmod_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-rtmod1/recipes-training/rt-demoapps/rt-demo-kmod_1.0.bb')
-rw-r--r--meta-rtmod1/recipes-training/rt-demoapps/rt-demo-kmod_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-rtmod1/recipes-training/rt-demoapps/rt-demo-kmod_1.0.bb b/meta-rtmod1/recipes-training/rt-demoapps/rt-demo-kmod_1.0.bb
new file mode 100644
index 0000000000..19a0839f12
--- /dev/null
+++ b/meta-rtmod1/recipes-training/rt-demoapps/rt-demo-kmod_1.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "RT sysfs notify example Linux kernel module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+
+inherit module
+
+SRC_URI = "file://Makefile \
+ file://rt-demo-kmod.c \
+ file://COPYING \
+ "
+
+S = "${WORKDIR}"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.
+
+RPROVIDES_${PN} += "kernel-module-demo"