aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2021-11-15 14:29:13 +0000
committerAlex Bennée <alex.bennee@linaro.org>2021-11-16 16:19:53 +0000
commita399f9143e801efbc574495c7df0eba3bd729e9f (patch)
tree3acdba64399b74770dbff8d2d0d14ae674b1d681 /meson.build
parentebd654aabc1a9128b2ea390faa23c2fb6b4b13b8 (diff)
meson: remove useless libdl test
dlopen is never used after it is sought via cc.find_library, because plugins use gmodule instead; remove the test. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com> Reviewed-by: Thomas Huth <thuth@redhat.com> Message-Id: <20211110092454.30916-1-pbonzini@redhat.com> Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20211115142915.3797652-5-alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 1 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 2ece4fe088..baeaee4522 100644
--- a/meson.build
+++ b/meson.build
@@ -566,13 +566,7 @@ endif
spice_headers = spice.partial_dependency(compile_args: true, includes: true)
rt = cc.find_library('rt', required: false)
-libdl = not_found
-if 'CONFIG_PLUGIN' in config_host
- libdl = cc.find_library('dl', required: false)
- if not cc.has_function('dlopen', dependencies: libdl)
- error('dlopen not found')
- endif
-endif
+
libiscsi = not_found
if not get_option('libiscsi').auto() or have_block
libiscsi = dependency('libiscsi', version: '>=1.9.0',