aboutsummaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2015-05-05 13:38:00 +0100
committerNick Clifton <nickc@redhat.com>2015-05-05 13:38:00 +0100
commit837a17b36c9e297f4bf33727e25dfa9f38360c17 (patch)
tree5cf6ecb482076cf1e20e437b6ea94c00c87cb103 /ld/Makefile.am
parentb76f99d702c3501ac320396ea06bc7f9237173c3 (diff)
Add support to the MSP430 linker for the automatic placement of code and data into either low or high memory regions.
gas * config/tc-msp430.c (MAX_OP_LEN): Increase to 4096. (msp430_make_init_symbols): New function. (msp430_section): Call it. (msp430_frob_section): Likewise. ld * emulparams/msp430elf.sh (TEMPLATE_NAME): Change to msp430. * scripttempl/msp430.sc (.text): Add .lower.text and .either.text. (.data): Add .lower.data and .either.data. (.bss): Add .lower.bss and .either.bss. (.rodata): Add .lower.rodata and .either.rodata. * emultempl/msp430.em: New file. Implements a new orphan placement algorithm that divides sections between lower and upper memory regions. * Makefile.am (emsp430elf.c): Depend upon msp430.em. *emsp430X.c): Likewise. * Makefine.in: Regenerate.
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index 15f89946ac..ee22e75910 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -1529,9 +1529,11 @@ emn10300.c: $(srcdir)/emulparams/mn10300.sh \
$(ELF_DEPS) $(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
emsp430elf.c: $(srcdir)/emulparams/msp430elf.sh \
+ $(ELF_DEPS) $(srcdir)/emultempl/msp430.em \
$(ELF_GEN_DEPS) $(srcdir)/scripttempl/elf32msp430.sc ${GEN_DEPENDS}
emsp430X.c: $(srcdir)/emulparams/msp430elf.sh $(srcdir)/emulparams/msp430X.sh \
+ $(ELF_DEPS) $(srcdir)/emultempl/msp430.em \
$(ELF_GEN_DEPS) $(srcdir)/scripttempl/elf32msp430.sc ${GEN_DEPENDS}
ends32elf.c: $(srcdir)/emulparams/nds32elf.sh \