summaryrefslogtreecommitdiff
path: root/recipes-misc
diff options
context:
space:
mode:
authorJ. Michael Welsh <mike.welsh@arm.com>2019-01-28 15:54:32 -0600
committerJ. Michael Welsh <mike.welsh@arm.com>2019-01-28 16:39:38 -0600
commitcfbff0c8b5cdafe6b96c6853bbc79678ab9a8344 (patch)
treef3342357c4633a7d27e410a00dcfada83bfc06ed /recipes-misc
parenta75a60e052c0a0f0c20b429f2e93cb557c329f6e (diff)
Added in as much of the WigWag Meta will build.
Signed-off-by: J. Michael Welsh <mike.welsh@arm.com>
Diffstat (limited to 'recipes-misc')
-rw-r--r--recipes-misc/iqaudio-mute/files/init9
-rw-r--r--recipes-misc/iqaudio-mute/iqaudio-mute_1.0.bb24
-rw-r--r--recipes-misc/serialecho/serialecho_git.bb17
-rw-r--r--recipes-misc/spiloop/spiloop_git.bb17
-rw-r--r--recipes-misc/term-prompt/files/term-prompt.sh12
-rw-r--r--recipes-misc/term-prompt/term-prompt_0.1.bb18
6 files changed, 97 insertions, 0 deletions
diff --git a/recipes-misc/iqaudio-mute/files/init b/recipes-misc/iqaudio-mute/files/init
new file mode 100644
index 0000000..9638ffa
--- /dev/null
+++ b/recipes-misc/iqaudio-mute/files/init
@@ -0,0 +1,9 @@
+#!/bin/sh
+# Set gpio22 high, this enables (unmutes) the IQAudio DigiAMP
+
+if [ ! -d /sys/class/gpio/gpio22 ]; then
+ echo 22 > /sys/class/gpio/export
+ echo high > /sys/class/gpio/gpio22/direction
+else
+ echo 1 > /sys/class/gpio/gpio22/value
+fi
diff --git a/recipes-misc/iqaudio-mute/iqaudio-mute_1.0.bb b/recipes-misc/iqaudio-mute/iqaudio-mute_1.0.bb
new file mode 100644
index 0000000..a6d1a45
--- /dev/null
+++ b/recipes-misc/iqaudio-mute/iqaudio-mute_1.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "IQAudio Pi-DigiAMP+ gpio mute pin enable"
+HOMEPAGE = "http://www.jumpnowtek.com/"
+SECTION = "console"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI += "file://init"
+
+PR = "r0"
+
+S = "${WORKDIR}"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "iqaudio-mute-gpio"
+INITSCRIPT_PARAMS = "start 30 5 ."
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${S}/init ${D}${sysconfdir}/init.d/iqaudio-mute-gpio
+}
+
+FILES_${PN} += "${sysconfdir}"
diff --git a/recipes-misc/serialecho/serialecho_git.bb b/recipes-misc/serialecho/serialecho_git.bb
new file mode 100644
index 0000000..5aaabb6
--- /dev/null
+++ b/recipes-misc/serialecho/serialecho_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Utility to test serial ports in a loopback configuration"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRCREV = "7acc974041f2e8cb55f892140b306a8c76093811"
+SRC_URI = "git://github.com/scottellis/serialecho.git"
+
+S = "${WORKDIR}/git"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 serialecho ${D}${bindir}
+}
+
+FILES_${PN} = "${bindir}"
diff --git a/recipes-misc/spiloop/spiloop_git.bb b/recipes-misc/spiloop/spiloop_git.bb
new file mode 100644
index 0000000..895264a
--- /dev/null
+++ b/recipes-misc/spiloop/spiloop_git.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Utility to test spidev in a loopback configuration"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRCREV = "cc1deb3c947ddc04966805b7ebff45ada4f2535c"
+SRC_URI = "git://github.com/scottellis/spiloop.git"
+
+S = "${WORKDIR}/git"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 spiloop ${D}${bindir}
+}
+
+FILES_${PN} = "${bindir}"
diff --git a/recipes-misc/term-prompt/files/term-prompt.sh b/recipes-misc/term-prompt/files/term-prompt.sh
new file mode 100644
index 0000000..14c4b4f
--- /dev/null
+++ b/recipes-misc/term-prompt/files/term-prompt.sh
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+# if not running interactively, don't do anything
+[ -z "$PS1" ] && return
+
+export TITLEBAR='\[\033]0;\u@\h: \w\007\]'
+
+case "$TERM" in
+xterm*|rxvt*)
+ export PS1="$TITLEBAR$PS1"
+esac
+
diff --git a/recipes-misc/term-prompt/term-prompt_0.1.bb b/recipes-misc/term-prompt/term-prompt_0.1.bb
new file mode 100644
index 0000000..e553198
--- /dev/null
+++ b/recipes-misc/term-prompt/term-prompt_0.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Add environment variable to show user@host in remote titlebar"
+
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRC_URI = "file://term-prompt.sh"
+
+PR = "0"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${sysconfdir}/profile.d
+ install -m 0755 term-prompt.sh ${D}${sysconfdir}/profile.d
+}
+
+FILES_${PN} = "${sysconfdir}"
+