summaryrefslogtreecommitdiff
path: root/recipes-misc
diff options
context:
space:
mode:
authorTravis McCollum <x85446@yahoo.com>2021-01-15 17:02:15 -0600
committerTravis McCollum <x85446@yahoo.com>2021-01-15 17:02:15 -0600
commit7c69b2ff068d521b8099f7e9bd4c1b3fc6b2152d (patch)
tree6c52156393501aec2a6175a9ba5d3f70c90845da /recipes-misc
parent36c15f4c85552714c8cbd9cb4de78dba6a55c4f5 (diff)
update
Diffstat (limited to 'recipes-misc')
-rw-r--r--recipes-misc/info-tool/info-tool_2.0.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-misc/info-tool/info-tool_2.0.0.bb b/recipes-misc/info-tool/info-tool_2.0.0.bb
new file mode 100644
index 0000000..971ada8
--- /dev/null
+++ b/recipes-misc/info-tool/info-tool_2.0.0.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Information command to display key Pelion stats"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/pe-utils/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI="\
+git://git@github.com/armPelionEdge/pe-utils.git;protocol=ssh;name=pe-utils;destsuffix=git/pe-utils \
+"
+
+#SRCREV_FORMAT = "wwrelay-dss"
+SRCREV_pe-utils = "365c21002df48f310c286b21a01c496d31929df7"
+
+inherit pkgconfig gitpkgv
+
+PV = "1.0+git${SRCPV}"
+PKGV = "1.0+git${GITPKGV}"
+PR = "r0"
+
+DEPENDS = ""
+RDEPENDS_${PN} += " bash curl bc"
+
+RM_WORK_EXCLUDE += "${PN}"
+
+FILES_${PN} = "\
+/wigwag/system/bin/ \
+/wigwag/system/lib/bash/ \
+"
+
+S = "${WORKDIR}/git"
+BINLOCATION = "${D}/wigwag/system/bin"
+LIBLOCATION = "${D}/wigwag/system/lib/bash"
+
+do_install() {
+ install -d ${BINLOCATION}
+ install -d ${LIBLOCATION}
+ install -m 0755 ${S}/pe-utils/info-tool/info ${BINLOCATION}/
+ install -m 0755 ${S}/pe-utils/info-tool/procinfo ${BINLOCATION}/
+ install -m 0755 ${S}/pe-utils/info-tool/json2sh ${BINLOCATION}/
+ install -m 0755 ${S}/pe-utils/info-tool/common.sh ${LIBLOCATION}/
+ install -m 0755 ${S}/pe-utils/info-tool/math.sh ${LIBLOCATION}/
+ install -m 0755 ${S}/pe-utils/info-tool/json.sh ${LIBLOCATION}/
+}
+