summaryrefslogtreecommitdiff
path: root/recipes-misc
diff options
context:
space:
mode:
authorTravis McCollum <x85446@yahoo.com>2021-01-14 20:23:30 -0600
committerTravis McCollum <x85446@yahoo.com>2021-01-15 19:52:28 -0600
commit544aa5d2f49de6edc99aecfd84381f6b7e6d380c (patch)
tree8b339e044254a0755415918033d1dbec1e099bc9 /recipes-misc
parent0efb5735df008821a64faa334628515c0e25ac2c (diff)
moves setting path to independent recipe
Diffstat (limited to 'recipes-misc')
-rw-r--r--recipes-misc/path-set/files/pelionpath.sh38
-rw-r--r--recipes-misc/path-set/path-set_0.0.1.bb19
2 files changed, 57 insertions, 0 deletions
diff --git a/recipes-misc/path-set/files/pelionpath.sh b/recipes-misc/path-set/files/pelionpath.sh
new file mode 100644
index 0000000..e365646
--- /dev/null
+++ b/recipes-misc/path-set/files/pelionpath.sh
@@ -0,0 +1,38 @@
+# Copyright (c) 2018-2021, Pelion and affiliates.
+# SPDX-License-Identifier: Apache-2.0
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+export HAVEGLOBAL="yes"
+export PS1='\h:\w\$ '
+umask 022
+
+# You may uncomment the following lines if you want `ls' to be colorized:
+color_prompt=yes
+PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\
+\[\033[00m\]\$ '
+# enable color support of ls and also add handy aliases
+if [ -x /usr/bin/dircolors ]; then
+ test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
+ alias ls='ls --color=auto'
+ alias grep='grep --color=auto'
+ alias fgrep='fgrep --color=auto'
+ alias egrep='egrep --color=auto'
+fi
+
+export NODE_PATH="/wigwag/devicejs-core-modules/node_modules/"
+export LD_PRELOAD="/usr/lib/libcrypto.so.1.0.2"
+export PATH="/wigwag/system/bin:/wigwag/system/lib:/wigwag/system/lib/bash:$PATH"
+export LD_LIBRARY_PATH="/wigwag/system/lib:/wigwag/system/lib/bash:$LD_LIBRARY_PATH"
+export BASHLIBS="/wigwag/system/lib/bash/:$BASHLIBS"
+
diff --git a/recipes-misc/path-set/path-set_0.0.1.bb b/recipes-misc/path-set/path-set_0.0.1.bb
new file mode 100644
index 0000000..d41fa9d
--- /dev/null
+++ b/recipes-misc/path-set/path-set_0.0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Adds needed paths to the profile for Pelion Edge programs"
+
+LICENSE = "APACHE-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://pelionpath.sh"
+
+PR = "r0"
+
+S = "${WORKDIR}"
+
+FILES_${PN} = "${sysconfdir}"
+
+do_install() {
+ install -d ${D}${sysconfdir}/profile.d
+ install -m 0755 pelionpath.sh ${D}${sysconfdir}/profile.d
+}
+
+