summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
authorTravis McCollum <x85446@yahoo.com>2019-04-24 15:05:50 -0500
committerNic Costa <nic.costa@gmail.com>2019-04-25 08:41:20 -0500
commita350fdb04836b6b73fe4ba50e15596373c556560 (patch)
tree0165f07d6166ccb381520c702c6f903f44669131 /recipes-extended
parent8db816f161d081f8a7abd9364e9fbee3ab92c352 (diff)
overidding crontab to rotate all logs on schedule
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/cronie/cronie/crontab15
-rw-r--r--recipes-extended/cronie/cronie_%.bbappend2
2 files changed, 17 insertions, 0 deletions
diff --git a/recipes-extended/cronie/cronie/crontab b/recipes-extended/cronie/cronie/crontab
new file mode 100644
index 0000000..207572f
--- /dev/null
+++ b/recipes-extended/cronie/cronie/crontab
@@ -0,0 +1,15 @@
+# /etc/crontab: system-wide crontab
+# Unlike any other crontab you don't have to run the `crontab'
+# command to install the new version when you edit this file
+# and files in /etc/cron.d. These files also have username fields,
+# that none of the other crontabs do.
+
+SHELL=/bin/sh
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+
+#m h dom mon dow user command
+*/10 * * * * root /usr/sbin/logrotate /etc/logrotate.conf > /wigwag/log/cron-logrotate.log 2>&1
+1 * * * * root cd / && run-parts /etc/cron.hourly
+30 7 * * * root cd / && run-parts /etc/cron.daily
+42 7 * * 7 root cd / && run-parts /etc/cron.weekly
+55 7 1 * * root cd / && run-parts /etc/cron.monthly
diff --git a/recipes-extended/cronie/cronie_%.bbappend b/recipes-extended/cronie/cronie_%.bbappend
new file mode 100644
index 0000000..6568cee
--- /dev/null
+++ b/recipes-extended/cronie/cronie_%.bbappend
@@ -0,0 +1,2 @@
+#prepend to take precedence over poky/meta
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"