summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
authorYash Goyal <Yash.Goyal@arm.com>2021-01-15 19:41:20 -0800
committerGitHub <noreply@github.com>2021-01-15 21:41:20 -0600
commit15f61bb3c2545399b627cb83bff29495bec42e03 (patch)
tree7dc83f9014959d9a6adc89b56342b60239757b8c /recipes-extended
parentdb8813a7c05f3fe2dcb6b56d912a6d184dbbe144 (diff)
Replacing the default meta-oe fluentbit service to work with Pelion setup (#207)
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/fluentbit/files/td-agent-bit.service3
-rw-r--r--recipes-extended/fluentbit/fluentbit_%.bbappend5
2 files changed, 6 insertions, 2 deletions
diff --git a/recipes-extended/fluentbit/files/td-agent-bit.service b/recipes-extended/fluentbit/files/td-agent-bit.service
index ef97e2f..cf08eb9 100644
--- a/recipes-extended/fluentbit/files/td-agent-bit.service
+++ b/recipes-extended/fluentbit/files/td-agent-bit.service
@@ -1,5 +1,6 @@
[Unit]
-Description=fast log collector
+Description=Fast log collector
+After=edge-proxy.service
[Service]
Restart=always
diff --git a/recipes-extended/fluentbit/fluentbit_%.bbappend b/recipes-extended/fluentbit/fluentbit_%.bbappend
index 9e22502..45ad718 100644
--- a/recipes-extended/fluentbit/fluentbit_%.bbappend
+++ b/recipes-extended/fluentbit/fluentbit_%.bbappend
@@ -18,12 +18,14 @@ FILES_${PN} += "\
"
SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \
+ file://${FB_PKG_NAME}.service \
file://${FB_PKG_NAME}.conf \
file://${FB_PKG_NAME}-watcher.service \
file://${FB_PKG_NAME}.path"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} += "${FB_PKG_NAME}-watcher.service \
+SYSTEMD_SERVICE_${PN} = "${FB_PKG_NAME}.service \
+${FB_PKG_NAME}-watcher.service \
${FB_PKG_NAME}.path"
do_install_append() {
@@ -33,4 +35,5 @@ do_install_append() {
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/${FB_PKG_NAME}-watcher.service ${D}${systemd_system_unitdir}/${FB_PKG_NAME}-watcher.service
install -m 0644 ${WORKDIR}/${FB_PKG_NAME}.path ${D}${systemd_system_unitdir}/${FB_PKG_NAME}.path
+ install -m 0644 ${WORKDIR}/${FB_PKG_NAME}.service ${D}${systemd_system_unitdir}/${FB_PKG_NAME}.service
} \ No newline at end of file