summaryrefslogtreecommitdiff
path: root/meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2020-08-28 17:04:34 -0300
committerRicardo Salveti <44008055+ricardosalveti@users.noreply.github.com>2020-09-08 11:44:16 -0300
commit2df56053f3ce073d9069ac7c5cce0ed9ea7dd64e (patch)
treec8ee177c0023ed35391bc74f83ffe93dbbc8a9e7 /meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend
parent45015e6f344d2b7a8907137c0e8da004904ea650 (diff)
bsp: u-boot-fio: mx8m: enable support for u-boot sign
Copy the correct dtb when u-boot sign is enabled, otherwise u-boot is unable to find the key during boot. Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
Diffstat (limited to 'meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend')
-rw-r--r--meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend12
1 files changed, 8 insertions, 4 deletions
diff --git a/meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend b/meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend
index a22bac9..8d7b646 100644
--- a/meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend
+++ b/meta-lmp-bsp/recipes-bsp/u-boot/u-boot-fio_%.bbappend
@@ -10,11 +10,15 @@ do_deploy_append_mx8m() {
i=$(expr $i + 1);
for type in ${UBOOT_CONFIG}; do
j=$(expr $j + 1);
- if [ $j -eq $i ]
- then
+ if [ $j -eq $i ]; then
install -d ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
- install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG}
+ # When sign is enabled the final DTB should be copied from deploy dir
+ if [ "${UBOOT_SIGN_ENABLE}" = "1" ]; then
+ install -m 0644 ${DEPLOY_DIR_IMAGE}/${UBOOT_DTB_IMAGE} ${DEPLOYDIR}/${BOOT_TOOLS}/${UBOOT_DTB_NAME}
+ else
+ install -m 0644 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
+ fi
+ install -m 0644 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG}
fi
done
unset j