aboutsummaryrefslogtreecommitdiff
path: root/debian/rules.d/0-common-vars.mk
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/0-common-vars.mk')
-rw-r--r--debian/rules.d/0-common-vars.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules.d/0-common-vars.mk b/debian/rules.d/0-common-vars.mk
index 8915c40826e..9022d53fad2 100644
--- a/debian/rules.d/0-common-vars.mk
+++ b/debian/rules.d/0-common-vars.mk
@@ -220,3 +220,8 @@ ifneq ($(LOCAL_ENV_CC),)
kmake += CC=$(LOCAL_ENV_CC) DISTCC_HOSTS=$(LOCAL_ENV_DISTCC_HOSTS)
endif
+# Locking is required in parallel builds to prevent loss of contents
+# of the debian/files.
+lockme_file = $(CURDIR)/debian/.LOCK
+lockme_cmd = flock -w 60
+lockme = $(lockme_cmd) $(lockme_file)