summaryrefslogtreecommitdiff
path: root/recipes-samples
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2018-06-13 17:47:33 -0300
committerRicardo Salveti <ricardo@opensourcefoundries.com>2018-06-13 17:49:18 -0300
commitbd6909b92eb5abb1bfb32b4d1d8ea2fb3e196b36 (patch)
treef31d252919b63816fbc28b8338fd03cbb35d80a1 /recipes-samples
parent5d1aac8a57ef73e593344799acc87e061efd0068 (diff)
images: move common base packages to lmp-image-common.inc
Move common base packages between lmp-mini-image and lmp-gateway-image to lmp-image-common.inc, easier to maintain the package list. This adds haveged and lmp-device-register, as both are also useful for the mini image target. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
Diffstat (limited to 'recipes-samples')
-rw-r--r--recipes-samples/images/lmp-gateway-image.bb5
-rw-r--r--recipes-samples/images/lmp-image-common.inc15
-rw-r--r--recipes-samples/images/lmp-mini-image.bb14
3 files changed, 15 insertions, 19 deletions
diff --git a/recipes-samples/images/lmp-gateway-image.bb b/recipes-samples/images/lmp-gateway-image.bb
index 48c9cc1..21d1b8b 100644
--- a/recipes-samples/images/lmp-gateway-image.bb
+++ b/recipes-samples/images/lmp-gateway-image.bb
@@ -6,7 +6,6 @@ IMAGE_FEATURES += "ssh-server-openssh"
# Base packages
CORE_IMAGE_BASE_INSTALL += " \
- 96boards-tools \
coreutils \
cpufrequtils \
ldd \
@@ -15,16 +14,13 @@ CORE_IMAGE_BASE_INSTALL += " \
htop \
iptables \
kernel-modules \
- networkmanager \
networkmanager-nmtui \
${@bb.utils.contains("MACHINE_FEATURES", "optee", "optee-test optee-client", "", d)} \
rsync \
sshfs-fuse \
- haveged \
"
CORE_IMAGE_BASE_INSTALL += " \
- aktualizr-host-tools \
docker \
bluez5-noinst-tools \
git \
@@ -33,7 +29,6 @@ CORE_IMAGE_BASE_INSTALL += " \
linux-firmware-ath10k \
linux-firmware-qca \
linux-firmware-wl18xx \
- lmp-device-register \
openssh-sftp-server \
packagegroup-core-full-cmdline-utils \
packagegroup-core-full-cmdline-extended \
diff --git a/recipes-samples/images/lmp-image-common.inc b/recipes-samples/images/lmp-image-common.inc
index 8bbad2b..3511c62 100644
--- a/recipes-samples/images/lmp-image-common.inc
+++ b/recipes-samples/images/lmp-image-common.inc
@@ -19,6 +19,21 @@ SRC_URI = "\
# let's make sure we have a good image..
REQUIRED_DISTRO_FEATURES = "pam systemd"
+# Base packages
+CORE_IMAGE_BASE_INSTALL += " \
+ 96boards-tools \
+ aktualizr-host-tools \
+ haveged \
+ networkmanager \
+ sudo \
+"
+
+# OTA+ extras (OSF device provisioning)
+CORE_IMAGE_BASE_INSTALL += " \
+ lmp-device-register \
+ python3-requests \
+"
+
fakeroot do_populate_rootfs_common_src () {
# Allow sudo group users to use sudo
install -m 0440 ${WORKDIR}/sudoers ${IMAGE_ROOTFS}${sysconfdir}/sudoers.d/lmp
diff --git a/recipes-samples/images/lmp-mini-image.bb b/recipes-samples/images/lmp-mini-image.bb
index 7a74ae2..96daa9c 100644
--- a/recipes-samples/images/lmp-mini-image.bb
+++ b/recipes-samples/images/lmp-mini-image.bb
@@ -4,20 +4,6 @@ require lmp-image-common.inc
IMAGE_FEATURES += "ssh-server-dropbear"
-# Base packages
-CORE_IMAGE_BASE_INSTALL += " \
- 96boards-tools \
- aktualizr-host-tools \
- networkmanager \
- sudo \
-"
-
-# OTA+ extras (OSF device provisioning)
-CORE_IMAGE_BASE_INSTALL += " \
- lmp-device-register \
- python3-requests \
-"
-
# Extras (for development)
CORE_IMAGE_BASE_INSTALL += " \
bash \