summaryrefslogtreecommitdiff
path: root/recipes-samples
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2017-10-15 02:58:58 -0200
committerRicardo Salveti <ricardo@opensourcefoundries.com>2017-10-15 02:59:00 -0200
commit8b7c68e8e80233e8e35231a7ecd70fdd0fa512d9 (patch)
tree3a506222b40f850927e2dff75d5a7958522b8408 /recipes-samples
parente26c7926c331068cd969e289ede705d2bf2f5ca3 (diff)
rpb-osf-gateway-image: remove packagegroup-rpb dependency
For now just move the packages required by packagegroup-rpb as part of the image, to be optimized later. Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com>
Diffstat (limited to 'recipes-samples')
-rw-r--r--recipes-samples/images/rpb-osf-gateway-image.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-samples/images/rpb-osf-gateway-image.bb b/recipes-samples/images/rpb-osf-gateway-image.bb
index a35b2b0..3433725 100644
--- a/recipes-samples/images/rpb-osf-gateway-image.bb
+++ b/recipes-samples/images/rpb-osf-gateway-image.bb
@@ -17,6 +17,23 @@ SRC_URI = "\
# let's make sure we have a good image..
REQUIRED_DISTRO_FEATURES = "pam systemd"
+# Base packages
+CORE_IMAGE_BASE_INSTALL += " \
+ 96boards-tools \
+ coreutils \
+ cpufrequtils \
+ gptfdisk \
+ hostapd \
+ htop \
+ iptables \
+ kernel-modules \
+ networkmanager \
+ networkmanager-nmtui \
+ ${@bb.utils.contains("MACHINE_FEATURES", "optee", "optee-test optee-client", "", d)} \
+ rsync \
+ sshfs-fuse \
+"
+
CORE_IMAGE_BASE_INSTALL += " \
docker \
bluez5-noinst-tools \
@@ -29,7 +46,6 @@ CORE_IMAGE_BASE_INSTALL += " \
packagegroup-core-full-cmdline-utils \
packagegroup-core-full-cmdline-extended \
packagegroup-core-full-cmdline-multiuser \
- packagegroup-rpb \
python3-compression \
python3-distutils \
python3-docker \