summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2016-02-09 13:45:10 +0000
committerNicolas Dechesne <nicolas.dechesne@linaro.org>2016-02-22 17:54:21 +0100
commit485c4a16594f8496008de8c6d4261224956f4916 (patch)
tree654c7bb9fda24a3ce8ea324dc1b172f616a23031
parentc4782ce3fabf87f97c4f353e48390fd3574a6754 (diff)
Add license, README and layer.conf
Change-Id: I9f5473a1f72a1b864988c51f6ca9f6a87e281d25 Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
-rw-r--r--COPYING.MIT17
-rw-r--r--README66
-rw-r--r--conf/layer.conf15
3 files changed, 98 insertions, 0 deletions
diff --git a/COPYING.MIT b/COPYING.MIT
new file mode 100644
index 0000000..fb950dc
--- /dev/null
+++ b/COPYING.MIT
@@ -0,0 +1,17 @@
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/README b/README
index e69de29..75f17f2 100644
--- a/README
+++ b/README
@@ -0,0 +1,66 @@
+Meta-backports
+================================
+
+Introduction
+-------------------------
+
+This layer is a place for backports against stable OpenEmbedded releases. For
+stable OpenEmbedded releases, only bug fixes are merged by the OE developers,
+and sometimes it might be useful to have newer versions of some components. This
+layer will provide such facility.
+
+We will accept backports from OE-core and meta-oe only, at least to start with.
+
+The meta-backports layer depends on:
+
+ URI: git://git.openembedded.org/openembedded-core
+ layers: meta
+ branch: master
+
+ URI: git://git.openembedded.org/meta-openembedded
+ layers: meta-oe
+ branch: master
+
+Please follow the recommended setup procedures of your OE distribution. For
+Angstrom that is http://www.angstrom-distribution.org/building-angstrom, other
+distros should have similar online resources.
+
+Notes
+-------------------------
+
+The recipes are organized by 'layer name' in the top level folder, such that
+recipes are parsed (and used) only if the corresponding layer is enabled in your
+current configuration. This is to avoid bringing un-needed (or even unexpected)
+dependencies into your build environment.
+
+Contributing
+-------------------------
+
+If you want to contribute changes, you can send Gerrit merge requests at
+https://review.linaro.org/#/q/project:openembedded/meta-backports.
+
+Alternatively you can send patches to openembedded@lists.linaro.org, in which
+case, please:
+
+* When creating patches, please use something like:
+
+`git format-patch -s --subject-prefix='meta-backports][PATCH' origin`
+
+* When sending patches, please use something like:
+
+`git send-email --to openembedded@lists.linaro.org <generated patch>`
+
+You can discuss about this layer, on `#linaro` on FreeNode IRC network.
+
+Reporting bugs
+-------------------------
+
+Please report any issue on:
+https://bugs.linaro.org/enter_bug.cgi?product=Linaro%20OpenEmbedded
+
+Maintainers
+-------------------------
+
+* Koen Kooi <koen.kooi@linaro.org>
+* Nicolas Dechesne <nicolas.dechesne@linaro.org>
+* Fathi Boudra <fathi.boudra@linaro.org>
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..e961f84
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,15 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+BBFILE_COLLECTIONS += "backports"
+BBFILE_PATTERN_backports := "^${LAYERDIR}/"
+BBFILE_PRIORITY_backports = "5"
+
+# Let us add layer-specific bbappends which are only applied when that
+# layer is included in our configuration
+# includes customization and/or backports
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
+# Add layer-specific bb files too
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"