aboutsummaryrefslogtreecommitdiff
path: root/meta-bigendian
diff options
context:
space:
mode:
Diffstat (limited to 'meta-bigendian')
-rw-r--r--meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch14
-rw-r--r--meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend3
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch b/meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch
new file mode 100644
index 00000000..b8b5ce02
--- /dev/null
+++ b/meta-bigendian/recipes-connectivity/openssl/openssl/aarch64_be-build.patch
@@ -0,0 +1,14 @@
+From: Victor Kamensky <victor.kamensky@linaro.org>
+Subject: add Aarch64 big-endian support
+Acked-by: Ard Biesheuvel <ard.biesheuvel@linaro.org>
+
+--- a/Configure
++++ b/Configure
+@@ -458,6 +458,7 @@ my %table=(
+ "linux-uclibceabi-arm","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "linux-uclibceabi-armeb","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+ "linux-aarch64","$ENV{'CC'}:-DL_ENDIAN -DTERMIO -O2 -pipe -g -feliminate-unused-debug-types -Wall -DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"linux-aarch64_be","$ENV{'CC'}:-DB_ENDIAN -DTERMIO -O2 -pipe -g -feliminate-unused-debug-types -Wall -Wa,--noexecstack -DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+
+ "linux-avr32","$ENV{'CC'}:-DTERMIO -O3 -fomit-frame-pointer -Wall::-D_REENTRANT::-ldl:BN_LLONG DES_RISC1:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).",
+
diff --git a/meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend b/meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend
new file mode 100644
index 00000000..3fec8ca8
--- /dev/null
+++ b/meta-bigendian/recipes-connectivity/openssl/openssl_1.0.1e.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+SRC_URI += "file://aarch64_be-build.patch"