aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro-toolchain/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-02-20 06:08:06 +0000
committerFathi Boudra <fathi.boudra@linaro.org>2015-02-20 08:11:13 +0200
commite6e66d3c93c571e82635ac1e5d83fffbcaaf144f (patch)
tree306e2e9966d443ddbac76796207313cdebc89a66 /meta-linaro-toolchain/recipes-devtools
parent3eaede2cfe054456b30d4f026916ed35aea21b04 (diff)
glibc,external-toolchain: spare the native and nativesdk recipe variants
We should make this change only when TARGET recipes are concerned since we use glibc for native and nativesdk providers even on uclibc and musl systems Change-Id: Ia93c5d808320516e856d77dee00479e653eea553 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools')
-rw-r--r--meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
index fc4e30eb..28ab4d78 100644
--- a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
+++ b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
@@ -410,7 +410,8 @@ python () {
if not d.getVar("ELT_VER_MAIN"):
raise bb.parse.SkipPackage("External Linaro toolchain not configured (ELT_VER_MAIN not set).")
import re
- if d.getVar("TCLIBC", True) != "glibc":
+ notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) and (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
+ if notglibc:
raise bb.parse.SkipPackage("incompatible with target %s" %
d.getVar('TARGET_OS', True))
}