aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2016-02-18 11:31:40 +0000
committerLinaro Code Review <review@review.linaro.org>2016-02-18 11:31:40 +0000
commit50968a21ecfcad515ccb09222edfa294917fd44e (patch)
tree792105c3166750c05487ddace097f47bcc76d54a
parentf5a05aaaedf2b14f84f8cdd93c8520f633c06e9e (diff)
parenta77ac4079d180640be313edd12ba6fc35a8e9730 (diff)
Merge "meta-linaro-toolchain: catch up with bitbake API change"
-rw-r--r--meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
index 05671c32..676b7ba1 100644
--- a/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
+++ b/meta-linaro-toolchain/recipes-devtools/external-linaro-toolchain/external-linaro-toolchain.bb
@@ -469,7 +469,7 @@ FILES_libgomp-staticdev = "\
ELT_VER_MAIN ??= ""
python () {
- if not d.getVar("ELT_VER_MAIN"):
+ if not d.getVar("ELT_VER_MAIN", False):
raise bb.parse.SkipPackage("External Linaro toolchain not configured (ELT_VER_MAIN not set).")
import re
notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) or (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)