aboutsummaryrefslogtreecommitdiff
path: root/debian/automake.mk
diff options
context:
space:
mode:
Diffstat (limited to 'debian/automake.mk')
-rw-r--r--debian/automake.mk14
1 files changed, 10 insertions, 4 deletions
diff --git a/debian/automake.mk b/debian/automake.mk
index ad347df7..7c656c8a 100644
--- a/debian/automake.mk
+++ b/debian/automake.mk
@@ -62,7 +62,13 @@ EXTRA_DIST += \
debian/rules \
debian/rules.modules
-dist-hook-debian-changelog:
- $(srcdir)/build-aux/update-debian-changelog '$(distdir)/debian/changelog' '$(VERSION)'
-DIST_HOOKS += dist-hook-debian-changelog
-EXTRA_DIST += build-aux/update-debian-changelog
+check-debian-changelog-version:
+ @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
+ then \
+ :; \
+ else \
+ echo "Update debian/changelog to mention version $(VERSION)"; \
+ exit 1; \
+ fi
+ALL_LOCAL += check-debian-changelog-version
+DIST_HOOKS += check-debian-changelog-version