aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-11-16 14:06:31 -0800
committerBen Pfaff <blp@nicira.com>2010-11-16 15:07:10 -0800
commitff8c6aa136118c65af50dd9dc8ed41b7fa2dcc03 (patch)
tree6dba06f0d6f7d5d1811b56a81e91f7d5dc88eae4 /debian
parent80642190644ae6fbcf485924b1c59e67d0be8a87 (diff)
debian: On "make check" failure dump the testsuite log.
The Debian automatic build machines don't save any files from the build, but they do preserve the build log, so dumping it to stdout is the only reasonable way to get test failure information.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index b1f9065c..6e99ff6e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -44,7 +44,10 @@ build-arch: build-arch-stamp
build-arch-stamp: configure-stamp
$(MAKE) -C _debian
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- $(MAKE) -C _debian check
+ if $(MAKE) -C _debian check; then :; else \
+ cat _debian/tests/testsuite.log; \
+ exit 1; \
+ fi
endif
touch $@