aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorThomas Goirand <zigo@debian.org>2012-03-09 13:49:36 -0800
committerBen Pfaff <blp@nicira.com>2012-03-19 10:25:21 -0700
commit9c06032b145b329dfd1adcd0f73fc631d1d50cc2 (patch)
tree140f316cc77709cc94d497d40f95d4b5942c91e9 /debian
parente3e13d047f9871e026206557933eeae1735b6a51 (diff)
debian: Remove some useless files from the dkms pacakge.
This commit removes useless files from the dkms package that caused lintian warnings. (Many of the other files in the dkms package are also useless but do not cause lintian warnings so they are less important.) Reviewed-by: Simon Horman <horms@verge.net.au> Signed-off-by: Thomas Goirand <zigo@debian.org> Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b65c460a..1953ee55 100755
--- a/debian/rules
+++ b/debian/rules
@@ -98,6 +98,16 @@ install-indep: build-indep
# Prepare dkms.conf from the dkms.conf.in template
sed "s/__VERSION__/$(DEB_UPSTREAM_VERSION)/g" debian/dkms.conf.in > debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/dkms.conf
+ # We don't need the debian folder in there, just upstream sources...
+ rm -rf debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/debian
+ # We don't need the rhel stuff in there either
+ rm -rf debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/rhel
+ # And we should also clean useless license files, which are already
+ # descriped in our debian/copyright anyway.
+ rm -f debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/COPYING \
+ debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/ovsdb/ovsdbmonitor/COPYING \
+ debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/xenserver/LICENSE
+
install-arch: build-arch
dh_testdir
dh_testroot