aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-11-09 08:35:33 -0800
committerBen Pfaff <blp@nicira.com>2011-11-10 09:08:37 -0800
commit77912ae717298cb06544f1bebd9701d0b3c2f2f0 (patch)
tree2e30cd1deb37255b65b7d420ae864094169a7fdc /debian
parentbb8b34795a1484332ad03d9d5db5cdcf97ed1bc6 (diff)
debian: Strip epoch from version number used in directory names.
This doesn't fix a visible bug, since there's no epoch in the Open vSwitch version used in Debian, but some Nicira internal build scripts were inserting an epoch so it was visible in our builds. Reported-by: Edwin Chiu <echiu@nicira.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index dd7c0fe4..c8b6c636 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,7 +15,7 @@ BUILD_NUMBER = 0
PACKAGE=openvswitch
pdkms=openvswitch-datapath-dkms
-DEB_UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-]+).*,\1,p')
+DEB_UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([0-9]:)*([^-]+).*,\2,p')
srcfiles := $(filter-out debian, $(wildcard * .[^.]*))
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))