aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-07-26 14:55:55 -0700
committerBen Pfaff <blp@nicira.com>2011-07-26 14:56:00 -0700
commit57483aeda3e10a190d401275c7b3dcde4cd121b4 (patch)
tree58935f6a14ca72964807b80bbbe326373c786385 /debian
parent54d54726993aec2a04542c76a69458f9c9244489 (diff)
debian: Fix bug from commit 211b05b5 "debian: Modernize use of dh_install."
Commit 211b05b5 "debian: Modernize use of dh_install" caused build failures in clean environments because debian/ovsdbmonitor.install now installed files that were never created in such an environment. It didn't cause a build failure in my own testing because I still had old files around. This fixes the problem. It seems to be necessary to run "make install" once for each of binary-arch and binary-indep, because dh_prep always deletes debian/tmp. It is logically not necessary but I don't see a clean and robust way to avoid it.
Diffstat (limited to 'debian')
-rw-r--r--debian/ovsdbmonitor.install4
-rwxr-xr-xdebian/rules1
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/ovsdbmonitor.install b/debian/ovsdbmonitor.install
index c34900c2..7e91e62d 100644
--- a/debian/ovsdbmonitor.install
+++ b/debian/ovsdbmonitor.install
@@ -1,2 +1,2 @@
-debian/openvswitch/usr/bin/ovsdbmonitor usr/bin
-debian/openvswitch/usr/share/openvswitch usr/share
+usr/bin/ovsdbmonitor
+usr/share/openvswitch
diff --git a/debian/rules b/debian/rules
index 224f095a..37d321b7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -74,6 +74,7 @@ install-indep: build-indep
dh_testroot
dh_prep -i
dh_installdirs -i
+ $(MAKE) -C _debian DESTDIR=$(CURDIR)/debian/tmp install
dh_install -i
sed 's/^BUILD_NUMBER = .*/BUILD_NUMBER = $(BUILD_NUMBER)/' \
< debian/rules.modules \