aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2012-03-09 14:20:54 -0800
committerBen Pfaff <blp@nicira.com>2012-03-19 10:25:22 -0700
commit4fe0f600d7f283afab68f4c32800fab89e86aaef (patch)
treedf558c5333115584d5b25acf3f2bc06f1cff3fc7 /debian
parentaf6641239aacdc277c4a6f6209c3bbc8e32cabd9 (diff)
debian: Avoid unit test failure when doing "unofficial" builds.
The configure option --with-build-number=0 is interpreted differently in different places. The configure script itself accepts 0 as an actual build number and puts '#define BUILDNR "+build0"' into config.h. The code in python/automake.mk treats 0 as "no build number" and puts 'BUILDNR = ""' into version.py. This commit avoids the problem by not passing 0 as a build number. Reviewed-by: Simon Horman <horms@verge.net.au> Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 1953ee55..4160025a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,6 +31,12 @@ else
CFLAGS += -O2
endif
+ifeq ($(BUILD_NUMBER),0)
+BUILD_NUMBER_OPTION =
+else
+BUILD_NUMBER_OPTION = --with-build-number=$(BUILD_NUMBER)
+endif
+
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -41,7 +47,7 @@ configure-stamp:
cd _debian && ( \
test -e Makefile || \
../configure --prefix=/usr --localstatedir=/var --enable-ssl \
- --sysconfdir=/etc --with-build-number=$(BUILD_NUMBER) \
+ --sysconfdir=/etc $(BUILD_NUMBER_OPTION) \
CFLAGS="$(CFLAGS)" $(DATAPATH_CONFIGURE_OPTS))
touch configure-stamp