aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-05-26 15:53:57 -0700
committerBen Pfaff <blp@nicira.com>2010-05-27 09:44:11 -0700
commit208d496f15787e55777c2ef541595f9e750ef771 (patch)
treef00491e11d424bb6b40da8a4125335254fb3e578 /debian
parent609d182a8161e9e87300cc680ff55c50d02b6e22 (diff)
debian: Attempt to keep debian/changelog up-to-date.
Invariably we forget to update the version number in debian/changelog as we change OVS's own version number. This is embarrassing. This commit introduces two different times to automatically update the debian/changelog version number: whenever boot.sh runs and whenever "make dist" runs. In the latter case, only the version number in the distributed tarball is updated, but that seems OK. Reported by Joan Cirer <joan@ev0.net> most recently, and by others over the last year or so too.
Diffstat (limited to 'debian')
-rw-r--r--debian/automake.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/automake.mk b/debian/automake.mk
index 1b649453..2658e392 100644
--- a/debian/automake.mk
+++ b/debian/automake.mk
@@ -61,3 +61,7 @@ EXTRA_DIST += \
debian/reconfigure \
debian/rules \
debian/rules.modules
+
+dist-hook:
+ $(srcdir)/build-aux/update-debian-changelog '$(distdir)/debian/changelog' '$(VERSION)'
+EXTRA_DIST += build-aux/check-structs