aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-11-16 14:09:41 -0800
committerBen Pfaff <blp@nicira.com>2010-11-16 15:07:10 -0800
commit6aa7dc839706a453f128a00f9040b31c597cfcfe (patch)
tree8ef8c1721660a4c40bd508b0a389a58a482675ae /debian/rules
parentff8c6aa136118c65af50dd9dc8ed41b7fa2dcc03 (diff)
debian: Fix parallel builds.
Some of the Debian automatic builds are failing apparently because the build-arch and build-indep targets are being called in parallel and they are both attempting to rebuild tests/testsuite at the same time, which doesn't work. We could make the OVS makefiles handle this particular case, but in general it's not a good idea to independently invoke a single makefile multiples times in parallel, so this commit avoids that problem. This also dumps the DEB_BUILD_OPTIONS variable to the log, because there doesn't appear to be any way to infer it from the automatic builders' log files.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 6e99ff6e..4a02a49e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,6 +29,7 @@ configure-stamp:
dh_testdir
test -e configure || ./boot.sh
test -d _debian || mkdir _debian
+ echo $(DEB_BUILD_OPTIONS)
echo $$CC
cd _debian && ( \
test -e Makefile || \
@@ -120,3 +121,9 @@ binary-arch: install-arch
binary: binary-arch binary-indep
.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure
+
+# This GNU make extensions disables parallel builds for the current Makefile
+# but not for sub-Makefiles. This is appropriate here because build-arch and
+# build-indep both invoke "make" on OVS, which can update some of the same
+# targets in ways that conflict (e.g. both update tests/testsuite).
+.NOTPARALLEL: