aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-10-05 10:42:34 -0700
committerBen Pfaff <blp@nicira.com>2011-10-12 16:27:09 -0700
commit9ea0bccc83a84458d934966eae15c78f3ee2bac8 (patch)
treeecf1a6b0e0667ab14a8d8a8af3ab007114468448 /configure.ac
parent09ded0ad489630236210a02f2d315816e558d701 (diff)
datapath-protocol: Use Linux kernel types directly.
We want datapath-protocol.h to be acceptable as a Linux kernel header, so it must use Linux kernel types and must not have references to Open vSwitch symbols or header files. This commit primarily makes that change to datapath-protocol.h. At the same time, at least for now we also want datapath-protocol.h to be usable on non-Linux platforms, so we need some kind of compatiblity. Thus, this commit also introduces a <linux/types.h> header file that defines the necessary Linux kernel types on non-Linux platforms. In turn, this requires openvswitch/types.h to use the Linux types directly for ovs_be<N>; otherwise, sparse complains because now __be<N> and ovs_be<N> are incompatible from its perspective, so this commit makes that change too. I don't have a non-Linux kernel platform readily available, so I only tested the non-Linux part of the linux/types.h substitute by forcing that case to be triggered with #if 0. It worked, except for errors in actual Linux kernel headers included explicitly from OVS source files, so I think it's likely to work in practice. Bug #7559. Signed-off-by: Ben Pfaff <blp@nicira.com> Acked-by: Jesse Gross <jesse@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7387d826..e771b50f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,7 +56,7 @@ OVS_CHECK_STRTOK_R
AC_CHECK_MEMBERS([struct stat.st_mtim.tv_nsec, struct stat.st_mtimensec],
[], [], [[#include <sys/stat.h>]])
AC_CHECK_FUNCS([mlockall strnlen strsignal getloadavg statvfs setmntent])
-AC_CHECK_HEADERS([mntent.h sys/statvfs.h])
+AC_CHECK_HEADERS([mntent.h sys/statvfs.h linux/types.h])
OVS_CHECK_PKIDIR
OVS_CHECK_RUNDIR