aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-07-21 15:38:23 -0700
committerBen Pfaff <blp@nicira.com>2010-07-21 15:38:23 -0700
commitc92647a47ad610ce188e29302c90ae6f7692dcb2 (patch)
tree6c80d48667f017f399f90ef8b0d58c110c7c652b /configure.ac
parent7454ec7a7494039ad339af5c0825fcc856bc6ffb (diff)
debian: Check for accurate Debian changelog version at build time too.
When we increment the Open vSwitch version number, we tend to forget to update it in debian/changelog at the same time. Right now this gets fixed up automatically at "make dist" time, but it's even better if we can always have it be correct in the repository. This commit should help with that, by making both "make" and "make dist" refuse to proceed if the version number is out of sync.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aff53a1f..5dd6590e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,7 @@ AM_PROG_CC_C_O
AC_PROG_CPP
AC_PROG_RANLIB
AC_PROG_MKDIR_P
+AC_PROG_FGREP
AC_ARG_VAR([PERL], [path to Perl interpreter])
AC_PATH_PROG([PERL], perl, no)