aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-04-12 11:43:11 -0700
committerBen Pfaff <blp@nicira.com>2011-04-12 13:41:36 -0700
commita64e37a1d3990b9c2524d166119cb5564dc5d96c (patch)
tree4eb9f491439e0ea0466e88ea2ed373c36cf4abe0 /configure.ac
parent024405698d676c4c4906ab12e9c2fbe02b5ad902 (diff)
configure: Add option --enable-Werror to add -Werror to CFLAGS.
-Werror is useful for development, but it screws up configure because it's impossible to guess what new warnings compilers will add in the future. This commit adds a new configure option to add CFLAGS after the configure checks are done. The use of AC_CONFIG_COMMANDS_PRE is based on Eric Blake's suggestion on the autoconf mailing list: "AC_CONFIG_COMMANDS_PRE probably fits the bill as the ideal macro to use for guaranteeing that you inject your shell code at the last possible moment." Requested-by: Andrew Evans <aevans@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5a2b5c0c..5b5f47ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,7 @@ OVS_ENABLE_OPTION([-Wmissing-field-initializers])
OVS_ENABLE_OPTION([-Wno-override-init])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
+OVS_ENABLE_WERROR
AC_ARG_VAR(KARCH, [Kernel Architecture String])
AC_SUBST(KARCH)