aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-03-24 13:15:41 -0700
committerBen Pfaff <blp@nicira.com>2010-03-24 16:52:07 -0700
commit9cb0788702e6187eafccabba0758095ced04552c (patch)
tree8072aa1e76da5e83a7530752573f64be3a6f4834 /configure.ac
parent5c43922c13983d2b5addf9e6dd3f54a006c568a6 (diff)
stream-ssl: Only re-read certificates and keys if they change.
Commit 415f6c0b1 "stream-ssl: Make no-op reconfiguration cheap" caused ovsdb-server to re-read its certificates and keys every 60 seconds just in case they changed. However, doing this causes OpenSSL to drop its connections. This commit solves the problem by making stream-ssl re-read certificates and keys only if the files changed. Bug #2535. Reported-by: Ram Jothikumar <rjothikumar@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1fc6a479..6d49484f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,8 @@ OVS_CHECK_PCRE
OVS_CHECK_PYTHON
OVS_CHECK_IF_PACKET
OVS_CHECK_STRTOK_R
+AC_CHECK_MEMBERS([struct stat.st_mtim.tv_nsec, struct stat.st_mtimensec],
+ [], [], [[#include <sys/stat.h>]])
OVS_CHECK_PKIDIR
OVS_CHECK_RUNDIR