aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-07-16 10:53:14 -0700
committerBen Pfaff <blp@nicira.com>2010-07-21 15:47:09 -0700
commit480ce8abca4ae262a4148fe757aebe3e0ddba6f6 (patch)
treecea1143781be3a75aab5c02c516a22fc7ca3d546 /configure.ac
parent5136ce492c414f377f7be9ae32b259abb9f76580 (diff)
vlog: Make the vlog module catalog program-specific.
Until now, the collection of vlog modules supported by a given OVS program was not specific to that program. That means that, for example, even though ovs-dpctl does not have anything to do with jsonrpc, it still has a vlog module for it. This is confusing, at best. This commit fixes the problem on some systems, in particular on ones that use GCC and the GNU linker. It uses the feature of the GNU linker described in its manual as: If an orphaned section's name is representable as a C identifier then the linker will automatically see PROVIDE two symbols: __start_SECNAME and __end_SECNAME, where SECNAME is the name of the section. These indicate the start address and end address of the orphaned section respectively. Systems that don't support these features retain the earlier behavior. This commit also fixes the annoyance that modifying lib/vlog-modules.def causes all sources files that #include "vlog.h" to recompile.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5dd6590e..dad2fb9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,7 @@ OVS_CHECK_MALLOC_HOOKS
OVS_CHECK_VALGRIND
OVS_CHECK_TTY_LOCK_DIR
OVS_CHECK_SOCKET_LIBS
+OVS_CHECK_LINKER_SECTIONS
AC_CHECK_FUNCS([strsignal])