aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-05-06 13:00:49 -0700
committerBen Pfaff <blp@nicira.com>2011-05-16 13:45:53 -0700
commit29d935d631c522c5e5915d6c0cb9a8af3a1f2390 (patch)
tree4e62f854a21569c7ac67faf2c166bfe19ca54484 /configure.ac
parent6506f45c0818618e96deb858bbabdf2cc90eb2df (diff)
configure: Run sparse automatically if C=1 specified on "make" command.
The C=1 convention matches the kernel's convention, so running "make C=1" will now get sparse results for both userspace and kernel compiles.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fe91242f..dde42e0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,6 +86,7 @@ OVS_ENABLE_OPTION([-Wno-override-init])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR
+OVS_ENABLE_SPARSE
AC_ARG_VAR(KARCH, [Kernel Architecture String])
AC_SUBST(KARCH)