aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-05-13 11:55:22 -0700
committerBen Pfaff <blp@nicira.com>2011-05-13 14:37:14 -0700
commit0e6644c3880be9684f37f48da84907bb67112514 (patch)
tree200eaf5525aa47c11d373ab76bae12528ad1d64e /configure.ac
parent498b2a5a68dcfea734f42ba548b7c61aabd8385b (diff)
backtrace: Make backtrace_capture() work on more systems.
The backtrace_capture() implementation only worked properly with GNU C on systems that have a simple stack frame with a frame pointer. Notably, the x86-64 ABI by default has no frame pointer, so this failed on x86-64. However, glibc has a function named backtrace() that does what we want. This commit tests for this function and uses it when it is present, fixing x86-64 backtraces.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5b5f47ed..fe91242f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,7 @@ AC_CHECK_HEADERS([mntent.h sys/statvfs.h])
OVS_CHECK_PKIDIR
OVS_CHECK_RUNDIR
+OVS_CHECK_BACKTRACE
OVS_CHECK_MALLOC_HOOKS
OVS_CHECK_VALGRIND
OVS_CHECK_SOCKET_LIBS