aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEthan Jackson <ethan@nicira.com>2012-10-12 15:18:26 -0700
committerEthan Jackson <ethan@nicira.com>2012-10-14 19:36:39 -0700
commit9d232a6d578e1283c543b0a40f5915e39813ac21 (patch)
tree1c440447059cab4c34202dad8c9df26bf5eb2a3b /configure.ac
parentb363bae4f802a07efec6e012075caf915e1e4fe5 (diff)
timeval: Add new "backtrace" appctl command.
Often, it can be quite difficult to debug performance issues in Open vSwitch. Typically one needs to run something like gprof, but that requires rebuilding and installing on the affected system which is often problematic. This patch adds a light weight profiling solution which can be used in these situations. The ovs-appctl backtrace command prints out backtraces taken at 100 millisecond intervals over a 5 second period of time. It is currently only supported on systems which have the execinfo library and enable time caching. Signed-off-by: Ethan Jackson <ethan@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6fb30fd2..ef513aa3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,7 +61,7 @@ OVS_CHECK_STRTOK_R
AC_CHECK_MEMBERS([struct stat.st_mtim.tv_nsec, struct stat.st_mtimensec],
[], [], [[#include <sys/stat.h>]])
AC_CHECK_FUNCS([mlockall strnlen strsignal getloadavg statvfs setmntent])
-AC_CHECK_HEADERS([mntent.h sys/statvfs.h linux/types.h])
+AC_CHECK_HEADERS([mntent.h sys/statvfs.h linux/types.h execinfo.h])
OVS_CHECK_PKIDIR
OVS_CHECK_RUNDIR