aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2009-11-23 16:07:36 -0800
committerBen Pfaff <blp@nicira.com>2009-11-23 16:07:36 -0800
commitd879a707a38eff0335e1b5c12ae4c61f4aa0296b (patch)
tree10d37b87a53ba1376e467a60bbe57cc355d7b7c9 /Makefile.am
parent6bf4c631ae776f4e936b5f01efe4bfbe190f5d99 (diff)
ovsdb: Add ovsdb IDL compiler to build system.
This first stab at any interface definition language and compiler for OVSDB will give other developers a chance to look at it and try to integrate it. The IDL is not actually implemented yet; I am working on that.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 22ebb219..4229cb1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,7 @@ else
AM_LDFLAGS = -export-dynamic
endif
+BUILT_SOURCES =
CLEANFILES =
DISTCLEANFILES =
EXTRA_DIST = INSTALL.bridge \
@@ -62,6 +63,7 @@ SUFFIXES = .in
-e 's,[@]localstatedir[@],$(localstatedir),g' \
-e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
-e 's,[@]sysconfdir[@],$(sysconfdir),g' \
+ -e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
> $@.tmp
@if head -n 1 $@.tmp | grep -q '#!'; then \
echo chmod +x $@.tmp; \